Getting logged out while posting

This forum is a collection of helpful tips about features on the board. If you want to learn about board features, this is the place to go. If you are curious about something then post a question
Post Reply
User avatar
soonerrick64
Posts: 36
Joined: Mon Jan 03, 2022 9:05 pm
Location: McKinney, TX

Getting logged out while posting

Post by soonerrick64 »

Hey Tom you've always been so helpful. I did finally just create a new user account to get back in again. But now I've run into another snag. I created the new user account so I could access this site from work over my lunch break as I don't always get a chance to get on at night. I'm able to get on at work, but I can't reply to any threads and I can't start any new threads for there. Everytime I do, it takes me to the log in screen. I log in again, create the new post or reply and hit submit, and it takes me back to the log in screen again in an endless loop. Help!
User avatar
OU_Tom
Posts: 1176
Joined: Sun Sep 26, 2021 12:36 pm
1
Has thanked: 147 times
Been thanked: 198 times

Post by OU_Tom »

Hi Rick. You are not alone with this problem. It definitely happens. It has happened a couple of times for me out of my 600+ posts. It happens more frequently with other especially safari users

I am going to add some more information to this thread and we can try to investigate/see if we can improve this issue for you

Maybe we can start with are you using safari/iphone wherever you are having this problem?

Try reading this
https://soonertimes.com/viewtopic.php?t=203


Especially the suggestions in the first post

Let me know if anything there helps.
::rice2:: :dude:
User avatar
soonerrick64
Posts: 36
Joined: Mon Jan 03, 2022 9:05 pm
Location: McKinney, TX

Post by soonerrick64 »

Tom I read the tips and I'll try tomorrow. However, after reading this I don't think that's the issue. We use Edge at work, and we can't use safari or Firefox as IT and Infosec determines most of these decisions "for us". I haven' had issues with other forums that I use. I don't think I have any control over cookies at work, and I think they are blocked by Infosec. If necessay I'll talk to my local Field Technology Specialist and see what he thinks and I'll let you know the outcome.
User avatar
OU_Tom
Posts: 1176
Joined: Sun Sep 26, 2021 12:36 pm
1
Has thanked: 147 times
Been thanked: 198 times

Post by OU_Tom »

Thanks Rick. Let's continue to work on this

I did change a CDN setting and a rewrite rule
Allow usage of third party content delivery networks:
If this setting is enabled, some files will be served from external third party servers instead of your server. This reduces the network bandwidth required by your server, but may present a privacy issue for some board administrators. In a default phpBB installation, this includes loading “jQuery” and the font “Open Sans” from Google’s content delivery network.
Enable URL Rewriting:
When enabled, URLs containing ’app.php’ will be rewritten to remove the filename (i.e. app.php/foo will become /foo). Apache server’s mod_rewrite module is required for this functionality to work; if this option is enabled without mod_rewrite support, URLs on your board may be broken.
Yes No
We are unable to determine whether or not this server supports URL rewriting. This setting may be enabled but if URL rewriting is not available, paths generated by this board (such as for use in links) may be broken. Contact your web hosting provider if you are unsure whether or not you can safely enable this feature.
Probably not your issues but it popped up while googling issues like yours
::rice2:: :dude:
User avatar
OU_Tom
Posts: 1176
Joined: Sun Sep 26, 2021 12:36 pm
1
Has thanked: 147 times
Been thanked: 198 times

Post by OU_Tom »

Does it matter how long it takes to post?

For example, post a 2 character response as fast as you can click on the keys.

Or does it happen only when it takes you 5 minutes to compose a thoughtful post?
::rice2:: :dude:
User avatar
soonerrick64
Posts: 36
Joined: Mon Jan 03, 2022 9:05 pm
Location: McKinney, TX

Post by soonerrick64 »

OK Tom, I tried to use your tricks but I don't have access to the cookies. I work for a huge company and they are very strict with what we have access to. The normal controls for Edge are not there and they won't give us access to them. InfoSec (the information Security Team) has some pretty strict rules. Such as if you're off a computer for more than five minutes you have to log in again. In fact, the process usually takes at least three log ins.............or what we call log in, to log in, to log in.

In answer to your other question it seems to be when I'm putting together one my posts......long winded as they are. But the other day, just a simple response that only took a couple of seconds logged me out and even if I log in again, and I still can't post a reply because it's this endless loop of log ins.
User avatar
OU_Tom
Posts: 1176
Joined: Sun Sep 26, 2021 12:36 pm
1
Has thanked: 147 times
Been thanked: 198 times

Post by OU_Tom »

Can you ask your InfoSec group what they do with cookies? If they are not allowing or limiting cookies in any way then that would definitely explain your problems. The board uses SSL which uses ‘secure’ cookies. We are running out of options if there are limits on cookies. Probably only other option is to use your phone to surf web in office; that is what I do.

If there aren’t any cookies limits then we can continue trying to figure out what is going on.
::rice2:: :dude:
User avatar
soonerrick64
Posts: 36
Joined: Mon Jan 03, 2022 9:05 pm
Location: McKinney, TX

Post by soonerrick64 »

OK I'll be talking to my local IT rep for the company on Monday. I'll ask him. If there is a workaround he'll know. Thanks for all you do Tom!
User avatar
soonerrick64
Posts: 36
Joined: Mon Jan 03, 2022 9:05 pm
Location: McKinney, TX

Post by soonerrick64 »

I finally got my IT guy in the store today. The company isn't going to give up control of the cookies. So, you guys are just stuck with me posting from home. I can read at work, but after I read each thread, it logs me out.

:surrender:
User avatar
OU_Tom
Posts: 1176
Joined: Sun Sep 26, 2021 12:36 pm
1
Has thanked: 147 times
Been thanked: 198 times

Post by OU_Tom »

Sorry to hear that Rick. Unfortunately I don't want to turn ssl off either.
::rice2:: :dude:
Post Reply

Create an account or sign in to join the discussion

You need to be a member in order to post a reply

Create an account

Not a member? register to join our community
Members can start their own topics & subscribe to topics
It’s free and only takes a minute

Register

Sign in